Index by title

Plugin IFP - LSIS

The plugin IFP - LSIS proposes several computational steps dedicated to the modeling of forest objects by continuous surfaces:

Creators

Method developed during the Ph.D of Jules Morel supported by IFP (http://www.ifpindia.org/) and LSIS (http://www.lsis.org/) .
Plugin extended with the support of AMAP (http://amap.cirad.fr) and the Computree Core Team.

License

The plugin IFP - LSIS is under LGPL license (http://www.gnu.org)

Step IFP_stepGetMinPtsPerSurface: Filter of minimum points

Description

This step filters a point cloud to keep only the minimum points per surface unit. Even though such local minima may often correspond to non-ground points because of occlusions generated by surrounding objects, this simple filter remains interesting, especially because it drastically reduces the amount of data. In practice, the raw TLS point cloud is projected into a fine regular 2D (x, y) grid and further are selected the points of minimum elevation in each cell. The resulting set of points serves as input data for the digital terrain model (DTM) algorithm. Generally speaking, the size of the 2D grid should be selected according to the expected DTM accuracy. The smaller the grid size, the higher the point density and the finer the DTM.

Path in the step explorer

Points → Filter → IFP_stepGetMinPtsPerSurface

Parameters

Input

Output

Step IFP_stepComputeMnt: Estimate the digital terrain model (DTM)

Description

This step extracts the Digital Terrain Model (DTM) from a point cloud based on local minima coming from the step _ IFP_stepGetMinPtsPerSurface_. The result is provided as a triangulated irregular network (TIN). The high point density and the sudden shifts in this density are handled by using a quadtree division of space to adapt the scale locally. In order to handle the holes created by occlusion, the terrain is modeled as an implicit function by the combination of implicit patches merged with compactly supported radial basis functions (CSRBF). Its surface is then extracted by polygonization using a marching cube like algorithm.

The method is made of three main steps:



Figure: Overview of the method : (1) iterative build of the quadtree, (2) filtering of points using histogram,
(3) filtering of points with the distance of neighbor centroids to the local patch, (4) merge of local patches
using CSRBF and polygonization of the surface.

Path in the step explorer

Raster / Image → Digital elevation models→ IFP_stepComputeMnt

Parameters

Parameters related to the quadtree division of space

Parameters controlling the histogram filtering

Parameters controlling the neighboring filtering

Parameters controlling the refinement of the polygonization

Input

Output

Step IFP_stepSmoothQSM: Transform a Quantitative structure model (QSM) into a continuous surface model

Description

This step aims at modeling tree structures with continuous surface models. To do so, the algorithm builds upon a TLS point cloud describing a tree and the corresponding QSM provided as a opf file. It relies on the division of space provided by the QSM to adjust smoothly and finely cylindrical quadratic shapes in place of the cylinders. The global implicit function is then computed by merging the local quadratic approximations with compactly supported radial basis functions (CSRBF). This modeling as an implicit surface appears as a lightweight alternative to smooth the noise inherent of forest TLS point clouds. Finally, a marching cube like algorithm produces the surface mesh for visualization.

Figure: Overview of the method for two cylinders adjusted on the point cloud describing a part of the trunk:
(a) cylinders of the QSM adjusted to the point cloud; (b) bounding boxes of the cylinders defining the space
partition; (c) local approximations with cylindrical quadrics and their CSRBF, (d) Extraction of geometric
model as the the zero levelset of the implicit function resulting of the merge of local approximations.

Path in the step explorer

Meshes → Create / Merge → IFP_stepSmoothQSM

Parameters

Input

Output

Step TK_StepNormalEstimator: Compute a consistent normal field from a point cloud

Description

This steps computes a consistent normal field for each sample; it is a preliminary processing step required by the Poisson surface reconstruction. A normal field is said to be consistent if the normal of each points lying on a surface points towards the same side of the surface.

We use the method introduced by Hoppe et al. (1992) to compute a normal n at each point p. For each point p, we compute the co-variance matrix C. We attribute to n the eigenvector of the matrix C corresponding to the lowest eigenvalue. By browsing a graph filled with the data set, we propagate the normals orientation. At the end of the process, the input point cloud is enriched with point-wise normals oriented consistently over the whole data set.

Path in the step explorer

Points → Normals → TK_StepNormalEstimator

Parameters

Input

Output

Step IFP_StepPoisson: Reconstruct a surface from an oriented point cloud

Description

The Poisson surface reconstruction (Kazhdan et al. (2006)) models the surface by an indicator function whose value is 1 inside the shape and 0 elsewhere. It approximates the gradient of this function by a vector field coming from the normals of the 3D points. The indicator function is then retrieved by solving a Poisson problem. This function is finally polygonized to extract the resulting surface. Kazhdan et al. (2013) improve the methods by using the position of the points as constraints in the optimization to limit the over-smoothing.

Note: This approach guarantees the indicator function to have finite boundary, i.e. to define a closed portion of space. Nevertheless, because the polygonization occurs in the bonding box depending on the input points, the resulting mesh surface can be open.

This step relies on the implementation of the PCL library Poisson surface reconstruction, which is based on Kazhdan et al. (2013).

Path in the step explorer

Mesh → Create/Merge → IFP_StepPoisson

Parameters

Input

Output

Step IFP_stepComputeMeshVolume: Estimate the volume of a closed surface mesh

Description

This steps compute the volume of a closed triangulated mesh. To do so, it considers each tetrahedron formed by the triangles of the mesh and the centroid of the mesh, then it computes their volume, and finally sums those signed volumes. The volume can also be computed by slice. In this mode, the mesh is divided along the Oz axis in closed sub-meshes. The volume is then computed for each sub-meshes.

Path in the step explorer

Mesh → Analyse → IFP_stepComputeMeshVolume

Parameters

Input

Output

.


Plugin IPF - LSIS

...english version

Le plugin IFP - LSIS est en cours de mise en place. Il vise à intégrer les travaux de la thèse de doctorat de Jules Morel.

Concepteurs

!

Développers :

License

Le plugin IPF - LSIS est sous licence propriétaire pour le moment.

Résumé des fonctionnalités

Documentation DOxygen