Project

General

Profile

Crashes during exporting

Added by Luck Manuel over 2 years ago

Hi,
I’m computing the QSM for single trees. Since I changed to beta 32 computetree is always crashing during exporting the QSM outputs. Calculating allometric corrections works and the resulting models do make sense.
The model resulting from the attached steps tree contains ~23000 cylinders and seems to be quite accurate.
My device properties:

OS Name: Microsoft Windows 10 Home
Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM): 32.0 GB
Free Space: 1.52 TB (1’671’126’351’872 bytes)

Thank you for any advice.

Manuel Luck


Replies (2)

RE: Crashes during exporting - Added by Hackenberg Jan over 2 years ago

Hi Luck

I quickly looked at your case. You use the step Center Point Clouds which shifts the whole cloud to 0,0,0. This is good, as my plugin does not work with larger coordiantes. I provided in my export step a functionality which does take a transformation matrix (the shift from the second step) and intends to apply it to each QSM. I never tested this functionality. Here might be the “bug”.

I cant test as I do not have your LAS file for executing the script.

Please try: Make Script one: Import LAS, shift LAS (your second step, Export LAS.)

The make a second step: Import your new created shifted LAS file and the contintue with setting up step 3-13 (voxelgrid til export). You can also just try to deacitave the Selection of a Transformation MAtrix Group. The window on the left when you reconfigure input results. Just deselect everything tagged with Transformation MAtrix.

Please let me know if this helps. I might have to deactivate the transformation in that case for the export if I cannot fix, but I am out of project time slowly.

Jan

RE: Crashes during exporting - Added by Luck Manuel over 2 years ago

Hi Jan

Thank you for the quick help. Seperating the two workingsteps helped.

Best wishes,

Manuel

    (1-2/2)