Project

General

Profile

Update planned for dependecie and compiler mabye?

Added by Hackenberg Jan 9 months ago

Hi Alexandre

every now and then I try to update either QT to get access to C++17 standard or try to upgrade OpenCV. Whenever I tried I failed as I had some conflicts and thought it is not good to spent time solving them, as this would also mean forking away from CT master. Nevertheless I especially really would love to have access to C++17 with for example std::optional to name one feature which I am missing. Also OpenCV has neural net stuff included, but not in 3.3.

Is there any plan to upgrade the platforms dependencies? I can offer my help as a tester here as well, as I would profit for named reasons .

Anyway great work so far, the platform is really nice.

Jan


Replies (2)

RE: Update planned for dependecie and compiler mabye? - Added by Piboule Alexandre 9 months ago

Hi Jan,

We are working hard on future Computree v6, where many dependencies will be updated.
After a very difficult 2019 year for platform evolution, due to problems in development resources, it’s going better and better this year, and Computree evolution will start again quickly.

For c++ version, for now we are at c++11, as we are using MSVC 2015 as windows Compiler.
But for Computree v6, we have planned to check if/how it is possible to switch to MSVC 2017 or MSCV 2019 (considering dependencies requirements). If it is possible, the use of c++17 would become possible also.

So no definitive answer for now, but this is clearly in our concerns, and if all goes well it could be available in v6.

Thanks for your proposal to help in tests.

Best regards.
Alexandre.

RE: Update planned for dependecie and compiler mabye? - Added by Hackenberg Jan 9 months ago

Hello Alexandre

that is good to hear. I will wait until I hear news...

Jan

    (1-2/2)