Batch mode or loop

Added by Martin Olivier over 6 years ago

Hello all,

I have a simple script I want to run in batch on several scenes. I cannot find many information about the batch mode in Computree. An other solution could be to use the loop step available in the last version but I couldn’t find find information either.
Is there someone who already used it and could explain it to me ?

Thank you


Replies (8)

RE: Batch mode or loop - Added by Manso Rubén over 6 years ago

Hi there,

Just borrowing Olivier’s question concerning the batch mode and loop steps.

Could anyone give a hint?


More specifically,

- can the batch mode be launched from the graphical interface or should an executable be run in the console (eg CompuTreeBatch.exe or linux equivalent)?

- if an executable is needed, should it be retrieved from the repository? I believe CompuTreeBatch is not included in the downloadable release.

- if it is the case, what’s the address to connect to through a Subversion client?


Merci à l’avance pour votre temps et veuillez m’excuser si les questions sont un peu bêtes.


RE: Batch mode or loop - Added by Tremblay Jean-François over 6 years ago


I actually have the same questions as both of you. During the conference in Sherbrooke, a command-line mode was mentioned, but information about it is either nonexistent or hard to find (I may be blind too, correct me if I’m wrong). Running scripts without the GUI overhead would be really useful for me, and as Mr. Olivier said I need to run the same script on a big number of scenes.

Best Regards,


RE: Batch mode or loop - Added by Piboule Alexandre over 6 years ago


Using the batch mode is relatively simple, it is only needed to use the following command (on windows, same with .sh on linux):

CompuTreeBatch.exe -script scriptName.xsct2 -startSteps

The only problem is I’ve not provided the ComputreeBatch.exe / .sh file with the 4.0 release (sorry for that).
Here is the download for windows with a launch.bat example file doing also a copy of the log file for each script run:

For linux I’ve not compiled it yet. So you have to compile youself or wait. Sorry again.

I will provide a more polished documentation and the windows / linux executables with the next minor release.

Best regards.
Alexandre Piboule.

RE: Batch mode or loop - Added by Hackenberg Jan over 6 years ago


I also need help. I have setup the batch file as described. My script runs without UI. After first script is finished, the batch mode tries to close CT to start a new CT for the second script. But also here, like in CT with UI, when trying to close CT it causes a crash.
The batch process waits for manual confirmation of the crash (windows dialog). Without one time clicking the next CT for the next Script is not started.


RE: Batch mode or loop - Added by Piboule Alexandre over 6 years ago

I had the same problem before, but it’ve solved it in commit 770 of computree core (tested on windows 7, 8 and 10).
So the executable provided in my last answer of this thread should work whiout this problem.

So my question: on which system are you working ?
Which version of computree batch do you use ?


RE: Batch mode or loop - Added by Hackenberg Jan over 6 years ago

I have for the moment commit 760. Because of the visualizer issues postet elsewhere. I can try to update to 770. Now I know if there is problems where to roll back.
The Computree batch I use is the one you send one time to me (I think that was before 770) when we set up Eric’s pipeline. Does not have a version name.

I will let one more computation finish. Then I would recompile and try out. Is the batch two posts above the right one to use?


RE: Batch mode or loop - Added by Hackenberg Jan over 6 years ago

I went to commit 770, recompiled and same issue.

RE: Batch mode or loop - Added by Hackenberg Jan over 6 years ago

For unkown reason the solution from commit 770 did not work for me. For others though it does. In my case I solved on windows level. I modified the registry entries. Just google “win 7 suppress crash dialog” or something like this and you find a solution outside computree if Alexandres solution does not work on your setup.